30 Kasım 2008 Pazar

Linux uzerinde Upgrade İşlemleri (PHP,Mysql,Apache)

Linux üzerinde çalışırken php, mysql, apache nin son sürümlerini kurmak istediğinizde depodan size en uygun olanı indirtiyorlar.

sudo apt-get install apache2

sudo apt-get install php5

Sıfır kurulum için tamam. Ama ya bu kurduğunuz versiyonu upgrade yada downgrade etmek istiyorsanız yada bu sürüm yerine son stabil olanı kullanmak istiyorsanız ?

O zaman yapılacaklar 2 ye ayrılıyor. Ya elle bunları deryeleceksiniz yada paket yöneticinizden ayarları değiştirip hangi durumda olan sürümü istediğiniz belirteceksiniz.

Kolay olan paket yöneticinizden indirdiğiniz dosyaların tipini değiştirmek.

Bende ubuntu var onun üzerinden gidersek ;

PHP kurulu version PHP Version 5.2.3-1ubuntu6

nano /etc/apt/sources.list dersek


ikinci satıra ;

deb http://packages.dotdeb.org stable all
deb-src http://packages.dotdeb.org stable all

yazın.

sudo apt-get update -- böylece stable relase ler bulunacak

sudo apt-get install php5

yazınca zaten php5 kurulu olduğu için upgrade yapıp yapmak istemediğimizi soracak.

Y deyip geçiyoruz.

Tekrar bir soru gene "y"

işlem bitince php yi kontrol ediyoruz.

PHP Version 5.2.6-0.dotdeb.1

Hiç yorum yok: